Patch saving/loading weirdnesses


#1
  1. Intermittently: Data encoder B for global and other settings sometimes needs to be spun vigorously before it responds. Can work around this but it makes the workflow suck
  2. When naming or renaming a patch, there is some weird latency where the name/rename does not show up, only an underline. Somehow, by going up menu and back, after some time, the full name string appears, buyt NOT consistently.
    Frustrating but no show stopper

This one is a hair puller outer!
3) I have Parva set to load last saved, which works. Today, after loading a patch dedicated to tuning, I tried to Load my latest patch: Load -> scroll knob A to the patch (in the A bank if it matters; less than 64 total patches stored), then press A. The menu shifts back up a level, which usually indicates a successful patch change
However, the OLED screens STILL SHOW THE PREVIOUS PATCH!

OK, let us try this again! No change! I check in the Save menu, which USUALLY shows the CURRENT patch and it still shows the patch name dedicated to tuning!

So, I tried to switch off and on, to see if autoload works: first cycle NO, tuning patch still loaded (because it was the last SUCCESSFULLY saved patch.

Loaded the work patch I wanted again, still not showing in OLED settings, so off and on again the Parva and FINALLY, I have the working patch loaded!

This last behavior has no CONSISTENT work around, other than thrashing until it finally works.

Is this behavior indicative of:
A) Faulty A knob?
B) Flakey memory management?
C) Electro-plasmic POSSESSION by a demon of digital synth gods?

These issues seem to be newly emergent, or I would have been frustrated far sooner.
Though I have only used 2/3’s of Bank A, is it time to delete patches to clear this up?

Advice needed!


#2

None of those are “normal” bugs.

I’m not sure what to say about 1 or 2 right now, but for #3 does the A knob button press exhibit strange behavior in other menus? It almost sounds like the press action is being interpreted as the long press action – returning to the previous menu without loading the patch.

Other things to try:

  1. Is there anything else sending MIDI while this is going on? Processing large amounts of MIDI data could cause other functions to become unresponsive.

  2. Try re-flashing the mainboard firmware (mainboard only, not voice cards)


#3

Thanks for the quick and SENSIBLE reply.
Issues 2 and 3 are related to the PROPER operation of the A knob.
I was trying to hard pressing too hard! So Parva changed menu levels instead of performing the action AT that level.

Please pardon the operator error noise!

The intermittent data encoder unresponsiveness I will address with many spins on bootup!
Thanks!