Firmware v61 Release


#1

Changes

  • Fixed various voicecard issues
  • Fixed voicecard firmware update function
  • Fixed voice allocation and sustain pedal issues
  • Fixed crash when loading 8-slot multi patch
  • Changed Filter Resonance parameter mapping
  • Changed LFO Rate parameter mapping
  • Changed Glide parameter mapping: smaller is faster
  • Added fixed time and fixed rate glide options (Voice menu | Legato)
  • Added poly portamento
  • Added LFO S&H slew rate limiter (smooth random)
  • Added key tracking mod source (Note)
  • Added manual fine-tuning of individual voices
  • Added support for pitch bend RPN
  • Added MPE support

New firmware utility: Windows / MacOS

Parva Firmware v61 bundle

Please use the new firmware utility (v0.6) to perform the update. Install the mainboard firmware first, then update the voicecards. If you run into any problems with the update process, you can contact me directly at support@futureson.us for the fastest response.


Using Parva with Linnstrument issues
Black friday... update?
#2

I don’t see this available for download. ETA? Can’t wait to try it out.


#4

#5

#6

#7

The firmware update instructions are here: Parva Software and Firmware Downloads


#8

Just confirming that the update utility for Mac doesn’t run on 10.6.8 ?

I guess I’ll take the Parva upstairs to the Win10 machine to do the update instead.


#9

It should run on 10.6.8.

EDIT: Sorry, it requires 10.7. I will try to recompile for the older version, but it’s getting harder and harder with these new tools.


#10

Thanks for the update! MPE mode is awesome!


#11

Brad - don’t spend any time doing that. Just have a note somewhere saying what minimum versions are supported. I have to unplug the Parva and move it anyway (the computer is not a big part of the music setup), so across the room or upstairs are about the same.

I’d update if I knew that the hw I talk to (Weiss AFI-1 and M-Audio Profire 610) had updated drivers and that Tracktion 5 ran OK on it and I had a full day to screw around doing OS and app/driver updates. Since the Mac is very stable and just works, I haven’t had time or energy to mess around with it.


#12

Tried a Windows update. The ParvaUtil executable window is filled with these error messages:

MidiOutWinMM::openPort: error creating Windows MM MIDI output port.
MidiInWinMM::openPort: error creating Windows MM MIDI input port.
MidiInApi::setCallback: a callback function is already set!

The mainboard did update to 0.61 but so far the voicecard update isn’t happening.

Windows 10 Home running on an Intel NUC.


#13

I got the same error messages, but the voicecard update did seem to work for me regardless.


#14

Are any other midi related programs open? Windows only allows one program to access a midi port at one time.


#15

That could well have been the cause of the error messages in my case. I just tried opening parvautil.exe again after making sure no other midi devices were open, and I got no error messages. I will say that the utility does not yet seem to work very well with my Windows 10 graphics (not a unique problem by any means) – tiny little box, hard to read, and not resizeable by dragging border). But, on my system it has gotten the firmware update job done, which is what matters. Will this version of the utility also transmit sysex patch files to the parva like the prior one, or is that a refinement still to come?


#16

The window is big enough to hold the two buttons, which is all that really matters. Even if the window was resizable, the text wouldn’t resize. It responds to the system dpi settings, though – if your text and icons are big, the utility will be big. If your text and icons are small, the utility will be small.

This is just a firmware update utility, and was designed to eliminate pretty severe issues with the previous app. I’ve decided to make the patch librarian (and other features) a separate app, likely limited to modern OS versions. The old ParvaUtil will still send/receive patches, though, if you need that now.


#17

No other MIDI programs open. This is the house computer the kids use for browsing, school work, other random stuff. I tried running as me and as administrator, same results.

After booting the Parva while holding down the A knob, the logo appeared and nothing ever changed after that. The utility said it was doing something, but the Parva never reacted and didn’t restart or anything.

I was on 0.51 on the voicecards.


#18

That sounds right. If the firmware utility can’t open the MIDI port, it can’t communicate with the Parva.

When the Parva is plugged in to the computer, is it recognized as a MIDI device?


#19

Funny thing - MIDI-Ox sees it as a MIDI device for in and out connections. However, when I try to select it, I get an error message saying:

Parva Synth: There is not enough memory available for this task. Quit one or more applications to increase available memory, and then try again.

Task Manager shows 3.9 Gb out of 16 being used (12 free), so something weird is going on.

Device Manager is showing Parva Synth under Sound, video, game controllers and it’s using a Microsoft driver version 10.0.14393.0 from July of 2016.

Not to sound like a Luddite or anything, but this is why I haven’t done any upgrades on the Mac music computer. I don’t have a day to screw around with updates and troubleshooting on my computers. I have 2 repairs I really need to finish and another synth coming in next week, and I have to travel late next week.

I understand the difficulty of supporting every hw/sw combo out there - I write software for a living and it’s deployed on a variety of systems and networks. When I get a system at home that’s stable and works for my needs, I leave it alone as much as possible. That’s also why my personal preference is for music hardware rather than an ITB solution.


#20

^ I’m getting the same ‘not enough memory’ error in MIDI-OX with other devices too (didn’t try to connect Parva though). I assume it’s recent Win + MIDI-OX issue.


#21

Anyone else unable to name saved new patches since this update? I can save new patches but am currently unable to name these. The naming function just flashes but I cannot scroll through the letters or numbers etc. white cursor flashes but that’s all.